Proton 5.9-GE-6-ST ar d3d12.dll FIX Steam Linux | Horizon Zero Dawn Complete Edition datorā Ubuntu

Es jaunināju savu resursdatoru no Debian Lenny uz Debian Squeeze, un tagad mana CMS Made Simple vietne visā ekrānā izplata PHP kļūdas. Es domāju, ka es jaunināšu CMS, jo kādu laiku neesmu to izdarījis, taču Google Chrome man saka, ka CMS Made Simple vietne ir inficēta ar ļaunprātīgu programmatūru.

Kādas ir manas iespējas tagad?

Kļūdu piemēri:

Deprecated: Assigning the return value of new by reference is deprecated in /www/danmurn/cms/include.php on line 73 Deprecated: Assigning the return value of new by reference is deprecated in /www/danmurn/cms/include.php on line 162 Deprecated: Assigning the return value of new by reference is deprecated in /www/danmurn/cms/include.php on line 240 Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /www/danmurn/cms/include.php:73) in /www/danmurn/cms/include.php on line 34 Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /www/danmurn/cms/include.php:73) in /www/danmurn/cms/include.php on line 34 Deprecated: Function set_magic_quotes_runtime() is deprecated in /www/danmurn/cms/include.php on line 62 Deprecated: Assigning the return value of new by reference is deprecated in /www/danmurn/cms/lib/classes/class.global.inc.php on line 184 Deprecated: Assigning the return value of new by reference is deprecated in /www/danmurn/cms/lib/classes/class.global.inc.php on line 196 

Palaistā CMS versija nav saderīga ar PHP5. Jaunināšanai uz jaunāko versiju vajadzētu novērst problēmu, kā es pamanīju CMS Made Simple vietnē, viņiem tagad ir nepieciešama PHP 5.2 (kas ir labi).

Es no viņu vietnes nesaņemu kļūdas no ļaunprātīgas programmatūras no pārlūka Chrome, ja tā palīdz viņu lejupielāžu lapai: http://www.cmsmadesimple.org/downloads/

Kā īstermiņa labojumu jūs varētu mainīt kļūdas_ziņošanas vērtību php.ini, lai paslēptu šīs kļūdas, mēģiniet kaut ko līdzīgu:

error_reporting = E_ALL & ~E_DEPRECATED 

vajadzētu darboties, bet var būt citas problēmas, jums būs jāatjaunina ASAP.

  • Man šajā lapā ir kļūdas par ļaunprātīgu programmatūru, kā arī viņu wiki un foruma lapas.
  • Dīvaini, ka tagad saņemu arī brīdinājumus. Es atradu šo emuāra ziņojumu (kuru jūs, iespējams, nevarēsit apskatīt): cmsmadesimple.org/2011/02/Malware-Warning-on-cmsmadesimple-org, kas norāda, ka tā ir uzlauzta viņu reklāmas programmatūra un problēma ir novērsta , viņi vienkārši gaida pārskatīšanu no Google.
  • Labi, lai būtu drošībā, es lejupielādēju programmatūru links. Neviena ļaunprātīga programmatūra nevar jūs ietekmēt, ja jūsu pārlūkprogramma ir tik primitīva!
  • Un tagad es esmu pilnīgi pakļauts šļūtenēm - es mēģināju veikt jaunināšanu, un tas man saka Session not working, you have problem with some modules and functionality! Ask your provider, exiting!
  • Vai zināt, vai šī kļūda nāk no PHP vai CMS? Ja tas ir PHP, pārbaudiet / var / log / apache2 / error_log, vai nav norādījumu. Pārliecinieties arī, vai jums ir CMS dublējums (vismaz datu bāze), ja vēl nav par vēlu!

strādāja par jums: Charles Robertson | Vēlies ar mums sazināties?